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 Live Captioning 
(Chapter 7 of CaptionMaker Manual) 

 
Overview 
The CaptionMaker is designed for live realtime captioning using a steno machine. 
 
Additionally, it can also be used for: 
 

1. Budget realtime captioning using optional speed typing software.  
2. Budget realtime captioning using optional speech recognition software. 

 

DSP-1000 LED Display Device Beside captioning video with a standard closed caption 
encoder, you can also display captions on Museum Technology's LED display DSP-
1000/CC-1000 device. This is a 4 line 32 column LED display device.  
CaptionMaker can send caption data in Roll-up mode to this device via a serial 
connection. This is usually used for live caption for a large audience sitting in an 
auditorium. 

Realtime Captioning Using a Steno Machine 
For realtime captioning with a steno machine, you need:  
 

1. A steno machine (writer) to enter data at high speed.  
2. A high-speed computer with a sizable amount of memory to store a large dictionary, which is 

used to translate steno keystrokes into words.  
3. Realtime captioning software, which translates steno keystrokes into English and then sends that 

data to an encoder.  
4. A caption encoder to insert the caption data onto the video.  
5. A highly skilled court reporter (realtime captioner).  

 
Preparation and Fixes 
Before the show starts, the realtime captioner goes through the materials that will be covered in the show 
and enters all the proper names and new words that might not be in their dictionary. For a half-hour show 
the captioner sometimes needs to spend an additional half-hour or more to do this. 
 
Some TV stations rebroadcast their evening news later at night. You may have observed that the 
rebroadcast part of the late night news has virtually no captioning errors. This happens because the 
captioner has time to fix errors before the news is rebroadcast. At the time of rebroadcast, the captioner 
simply presses only one key to send one line of captions at a time from the script prepared earlier for the 
evening news. Since one whole line goes out at a time, captions are painted on the screen very smoothly 
from left to right. You can easily identify these captions. You may sometimes even see the captions 
appear before they are spoken! 
 
Captioning at the Top of the Screen 
Decoders adopting the new 1993 FCC/EIA specifications can support Roll-Up captioning at the top of the 
screen. All decoders manufactured before July, 1993, can only display Roll-Up captions at the bottom of 
the screen. If you have a new decoder or a new TV with a built-in decoder, you might sometimes see 
captions appear at the top of the screen to avoid conflicts with the graphics (names of people, etc.) at the 
bottom of the screen. Of course, the captioner has to make an extremely fast decision to move the 
captions to the top when necessary. If the captioner does not do that, even with the new decoders you will 
see captions covering graphics at the bottom. 
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Do Not Blame the Captioners for All Errors 
Not all the captioning errors on the TV news are the result of mistakes made by captioners. The 
captioners work under intense pressure, and it is quite possible that they make some errors. A good 
captioner normally does not make more than 2% errors. 
 
Errors can also arise because the caption information is a very sensitive signal encoded in a small area 
inside the video. If the picture reception on your TV is not very good, you will invariably see some 
mistakes in captions due to the distortions of the caption signal. 
 
The Ultimate Solution 
Ideally, if there were a machine (speech recognition) to translate the speech of all speakers into captions, 
you would not need highly skilled and expensive captioners. The expense factor prevents many TV 
stations from captioning the news. But the present speech recognition systems are still in their infancy. 
They cannot even interpret more than one speaker at a time. A large amount of research and money is 
being spent every year to make this technology feasible, but there is still a long way to go.  
 
Realtime Captioning and Steno Writing 
There are more than 20,000 court reporters in the United States. When they work in the courtroom 
environment they can afford to make some mistakes. They can fix the mistakes later and present the final 
corrected copy the next day (unless they are doing realtime reporting). In regard to realtime captioning, 
they do not have that luxury. Because the captions go out live instantly, there is no time for corrections. 
This is why not all court reporters are realtime captioners. In fact, only a small percentage (less than 2%) 
are certified as realtime captioners. Their average writing speed is around 250 words per minute. The 
steno machine has only 24 keys with thousands of possible keystroke combinations. There are 4 keys for 
vowels (A, O, E and U). To write a letter I, you need to press E and U together. The rest of the keys are 
divided into two parts. The left keys are for the beginning of a word, and the right keys are for the end 
part of a word. Left keys are S, T, K, P, W, H and R; and right keys are F, R, P, B, L, G, T, S, D and Z. 
Not all consonants are available as a single keystroke. For example, to write B, you need to press P and W 
together. You may press only one key, or as many as 10 keys all at the same time. Each keystroke, 
whether it is a single key or multiple keys, can produce a syllable, a word or even a phrase. It completely 
depends how you design your dictionary to respond to your keystrokes. It is astounding to think how it is 
possible to remember thousands of keystrokes. Of course, there are some standards which people follow. 
But every captioner adds their own keystrokes to their system. Here are you a few examples.  
 

Keystrokes English word(s) 
TH This 
g_ Is 
PW A_LS _D Balanced 
PWLTD SKWR_ET Budget 
SPH A_FT as a matter of fact

  
Captioners keep a number of phrases and abbreviations like this in their repertoire to attain writing speeds 
in excess of 250 wpm.  
 
Realtime Captioning Not Using a Steno Machine 
Since it is impossible type as fast as words are spoken, realtime captioning can only be done properly by 
using a steno machine. A professional realtime captioner can type more than 250 words per minute with 
over 99% accuracy using a steno machine. Due to their amazing skills, these professionals are quite 
expensive. 
 
For low-budget situations, there are two possible alternatives solutions that are not as good as realtime 
captioning with steno machines, but in some cases are acceptable. Instead of using the steno machine, text 
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can be entered using speed typing software or speech recognition software. The details can be found at 
the end of this chapter. 
  
Realtime Captioning Setup 
To set up for Live Caption, make sure to go though the following checklist.  
 

1. Open Ancillary Toolbar 
2. Invoke Full Screen Spreadsheet view 
3. Invoke Live Caption mode 
4. Set the desired choices to display captions 
5. Configure Encoder/Decoder 
6. Modem setup (if you are captioning from a remote location)  
7. Install software for text entry (steno machine, etc.) 
 

Open Ancillary Toolbar 
Go to the View menu and click the Ancillary Toolbar. At the right end of this toolbar you see icons 
pertinent to Live Captioning. Bring the mouse on top of each icon to view the tool tip and familiarize 
yourself with the function of each icon. The details can be found in the “Chapter 9: Icons and Buttons”. 
 

 
 
Invoke Full Screen Spreadsheet View 
It is much easier to caption live in the full-screen view as opposed to the screen with the video window. 
Click on the option under View → Full screen Speadsheet menu to set the full screen view. You may also 

click on the icon  to toggle between the two screens. 
 
Note: Do not use the view with video preview window. This window takes lot of processing power and 
slows down captioning. 
 
Invoke Live Caption Mode 
Click on the option under Caption → Live Caption menu to set the Live Caption mode. You may also 
click on the icon  on the ancillary toolbar to do the same. In Live Caption mode, CaptionMaker 
captions in the Roll-Up mode only. Roll-Up captions scroll up from the bottom (usually) of the screen 
one line at a time. Two to four lines of captions (maximum of 32 characters per line) normally appear on 
the screen at any given time. Television news and talk shows normally use Roll-Up captioning. 
 
Set the Desired Choices to Display Captions 
You can choose parameters like Caption Length, Number of lines in Roll-Up mode, Left Indentation etc. 
from the Caption → Live Caption Options menu. You may assign shortcut keys to invoke any of these 
options too. See “Chapter 8: Menus” for more details. Some of these options can be invoked either by 
clicking on the appropriate icons or by pressing multiple keystrokes. See the Tools → Customize 
Keystrokes menu. 
 
Number of Lines in Roll-Up Mode 
You can set up the maximum number of lines of captions you would like to see on the video screen at any 
given time (typically 3). Go to the menu option Caption → Live Caption Options and choose for Roll-Up 
3 Lines.  
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Tip     Make sure the Display column shows Roll-Up mode (not Pop-On or Paint-On). To 
change the mode, click on the Display header to highlight the column. Right-click 
anywhere on the column except the header and choose a mode.  

Caption Length 
Each line of text in the Work Area equals one caption line of up to 32 characters. You can choose to 
display less than 32 characters on a line if you so desire. If you choose an indentation other than 0, the 
length is reduced by that amount from 32. In other words, if you choose an indentation of 4, the 
maximum length allowable is 28. 
Indentation 
You may also choose the desired amount of indentation (i.e., the left margin). You may choose the icon 

 to do the same. 
 
Fast Indentation 
If you want to change the indentation on the fly, you may also do so by invoking any one of the 6 preset 
positions. 
 
Roll-Up One Blank Line 
This menu item sends one blank caption line to the video resulting in rolling up the existing caption on 
the video by one line. This option can also be used to clear captions on the video by invoking it several 

times to roll up existing captions of more than one line. You may choose the icon  to do the same. 
 
Font Height…  
The font height of the text seen on the CaptionMaker screen by the captioner in the Live Caption Mode 
can be changed. The choices are 9-point through 24-point type. A larger font is easier to read. The font 
height seen by home viewers cannot be changed.  
 
Send Option… 
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You may send the text to the closed caption encoder using either of the two options: 
 

• Send after each word 
• Send after each line 

 
For each option you may also choose a time delay. If the Time delay box is not checked, Send after each 
word option sends a word as soon as you press the space character. Send after each line option sends a 
line as soon as a line in completed and the cursor goes to the next line. You do not have any control to fix 
any word or line after the word or the line is sent to the encoder. 
 
On the other hand, if you check the Time Delay box and set the delay time to any time between 0 and 10 
seconds, you have time to fix any word or words that are not yet sent to the encoder.  
 
The above seven options are available from the Live Caption Option menu. You will also need to know 
about a few more options, which are described below. They are related to the vertical position and clear 
captions from the video screen and converting upper and lower case text into all upper case. You also 
need to know the status window, which shows some basic chosen parameters. 
 
Vertical Position 
You may caption at the top or the bottom of the screen. Choose the desired vertical position from the 
Attribute → Vertical Position menu or from the icons on the Ancillary Toolbar. You may choose Top 
(Vertical position =1), Bottom (Vertical position =15) or any position 1 through 4 or 12 through 15. Roll-
Up captions cannot be displayed with base line starting from lines 5 through 11. 
 

Click on the icon  to place the captions at the top of the screen. 
 

Click on the icon  to place the captions at the bottom of the screen. 
 

Click on the icons  to move the base row of Roll-Up captions up or down by one line. 
Clear Caption 
You may clear the caption on the video monitor by choosing Caption → Clear Caption menu option or, 

clicking on the icon  on the Ancillary Toolbar. 
 
Convert to uppercase 
You may convert upper and lower case text to all uppercase captions by checking the box Convert to 
uppercase option from the Caption → Properties → General Tab menu. 
 
Status Window 
At the bottom right side of the screen, a small window displays the default settings of the vertical (V) 
position, left indentation (L) and the choice of Lines for Roll-Up (R) mode. The default status is as 
follows: 
 

V15L00R3 
V15 indicates the vertical position is 15 which the bottom of the screen 
L00 indicates the left indentation is 0. 
R3 indicates Roll-Up 3 Line display mode. 
 

Configure Encoder/Decoder 
See “Chapter 2: Hardware Installation” to make sure you are properly connected to the Encoder/Decoder. 
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Modem Setup  
If you are captioning from a remote location, you have to make sure that your modem is properly 
connected. See “Chapter 2: Hardware Installation” for details. 
 
Install Software for Text Entry  
See the next section, “Realtime Captioning Using a Steno Machine” for details. 
 
Realtime Captioning Using a Steno Machine 
The CaptionMaker has been designed to accept text input from any one of the following devices, and then 
send the input text, line by line, to the caption device to produce captions: 

 

• Steno Machine running realtime court reporting software.  

• Speech recognition software. 

• Standard computer keyboard with or without speed typing software. 
 

This section will describe exactly how the CaptionMaker interfaces to a steno machine running any 
Windows realtime court reporting software. 
 

Note:   CaptionMaker works with any Windows realtime steno software as long as the 
text from the steno software is inserted to the keyboard buffer.  

 
A Windows steno software must be run in conjunction with CaptionMaker. Check the Steno software 
manual for details on: 
 

• Installing a steno software in the computer.  
• Which steno machine models you can use. 
• Built-in and user dictionaries.  
• Importing dictionaries from other court reporting systems. 
 

Live Captioning in Action 
Make sure that the Live Caption mode (inside the Caption menu) is checked. Type a short line of text on 
the computer keyboard and send the line by pressing the [+] key on the computer keyboard near the 
keypad area. If all the connections are correct, you will see the line of text appear as captions on the 
television screen, which indicates that the CaptionMaker software is working. 
 
To verify that both the CaptionMaker and the steno software are running fine together, type a few words 
on the steno machine and the text will appear on the computer screen. As the text being typed exceeds the 
caption length chosen, the text will wrap around on the computer screen and go out to the caption device 
to produce one line of captions on the television screen.   
 
Assigning Shortcut Keys from the Steno Machine 
You can assign keystrokes to your desired keys for any one of the Live Caption options using Customize 
Keystrokes under the Tools menu. Here is a list of recommended keystrokes for some realtime captioning 
options. 
 
Keystroke Option 
Ctrl+T  Top 
Ctrl+B  Bottom 
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Ctrl+K  Clear captions 
Ctrl+R  Roll up 1 blank line 
Ctrl+ ↑  Move up 1 line  
Ctrl+ ↓  Move down 1 line 
Ctrl+0  Left Indent 0 
Ctrl+1  Left Indent 4 
Ctrl+2  Left Indent 8 
Ctrl+3  Left Indent 12 
Ctrl+4  Left Indent 16 
Ctrl+5  Left Indent 20 
 
After you assign the proper keystrokes inside the CaptionMaker, you may assign shortcut keys to your 
steno keyboard to invoke any of those options. Consult the steno software manual for instructions. 
 
Live Mode Encoder Transparency 
To invoke this option, click on the item to “Close Device” inside the Caption Menu. 
 
When the caption device is closed, the caption encoder will be commanded to go into “transparent mode” 
to allow all existing caption data to pass through the caption encoder in tact. During Live caption 
encoding, closing the caption device allows upstream captions to pass through the caption encoder during 
commercials. Note that the caption encoder is automatically re-opened and re-initialized by 
CaptionMaker when you send any caption data to the caption encoder (continue typing in live mode, 
select “send caption” or “clear caption”, etc.). 
 
Instantly Switching Between Realtime and Live Display Captioning 
If you are captioning programs such as TV news, where you must caption some portions live and have 
text for other portions in advance, the CaptionMaker will enhance your captioning capability.  
 
To provide an example of how this works, this section will walk you through the process of captioning a 
TV news program, illustrating how easy it is to switch between live captioning and captioning with 
prepared text. Note that pre-recorded portions should be ready for use prior to live broadcast.  
 
The following chart and text provide an example of switching between Live Caption (Realtime) and Live 
Display (Post Caption). Live Display is used for segments that have been entered prior to airtime. 
 

Type of Segment Type of Captioning To Use 
Live report from field Realtime caption 

Pre-recorded segment Live Display 
Weather Realtime caption 

Pre-recorded segment Live Display 
Late breaking news story Realtime caption 

Pre-recorded segment Live Display 
 
The procedure is simple. Import or enter any text available prior to the news program. Whenever there is 
a live segment, enter text into the steno machine for realtime captioning. When you reach a segment of 
pre-recorded text, click on the desired caption and press a pre-assigned key on your steno machine (to 
mimic the [+] key on the computer keyboard) to output the line of text as captions. When the segment 
with prepared text is finished, resume realtime captioning on your steno machine. 
 
You will know the segment is finished when the text segment ends and the Talent begins another segment 
of live speaking. Note that the position of the cursor when ending one segment is exactly at the position to 
begin captioning the next prepared segment. 
 
A typical file will look like the following.  
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Notice the file has been created with the prepared text. The text in Red (gray) indicates the place where 
you enter text from the steno machine or from a speech recognition system. The blank rows send a blank 
line of caption in between the Live Display and Live Caption modes. 
 
To send a row of text (or blank line), simply press the [+] key from the keyboard or from the Steno 
Writer. 
 
Realtime Captioning Not Using a Steno Machine 
Since it is impossible to type as fast as words are spoken, realtime captioning can only be done properly 
by using a steno machine, which can be quite costly. For low-budget situations, there are two possible 
alternatives solutions that are acceptable in some cases. 
 
Budget Realtime Captioning with Speed Typing Software  
There are a few software packages on the market designed to enhance your typing speed. If your typing 
speed is around 70 wpm, you can increase your typing speed to 150 wpm or so after a few months’ 
practice. It works like macrotyping in some word processors. For example, you program this software so 
that every time you type “ys” and then press the space bar, it will replace “ys” with “Yours Sincerely”. 
Many secretaries at lawyers’ offices use this software to enhance their typing speed. 
 
If you take this route, you can type most of the words of a live event even if the speaker talks fast. 
CaptionMaker will simply send the words at the same speed you type. 
 
Contact CPC for information on speed typing software. 
 
Budget Realtime Captioning with Speech Recognition Software 
There are several software packages available, such as ViaVoice or Naturally Speaking, which can 
convert speech to text fairly well after you train the software to your voice. The more you train it, the 
better it gets. The main problem with these software packages is that they do not recognize a new voice, 
only the one they have been trained for. 
 

Dragon Naturally Speaking To use Dragon Naturally Speaking versions 7 and up with 
Captionmaker, it is necessary to execute a utility software called DnsIniFix. This utility 
will find the Naturally Speaking ini files on your computer and add an entry to them for 
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CaptionMaker. The utility software DnsIniFix.exe is available from 
www.cpcweb.com/download/cmplete_software_downloads.htm#Utilities  

 
With the aid of this software, if you can act somewhat like an interpreter who typically translates from 
one language to other for a live event, you can do live captioning fairly well. You do not have to translate, 
you just have to listen to the words from different speakers and repeat the words out loud, because the 
speech recognition software only recognizes your voice.  
 
If you are regularly a speaker for live events, you could train speech recognition software to your voice 
and then caption live using CaptionMaker software. 
 
First, run the speech recognition software and train the system to your voice. The more you train, better it 
understands you.  
 
Next, minimize the speech recognition software and open the CaptionMaker software and speak. The text 
of your speech will appear inside the CaptionMaker screen. As soon as a line of text exceeds the Total 
number of characters per line you have chosen, the text will wrap around on the screen, and the line will 
go out to the encoder and appear on the video as captions. 
 
You may also press the  [+] key to send an unfinished line at any moment if you want to. 
 
This function is available in only the Roll-Up display mode. Set the proper left and right margins and the 
maximum number of rows for Roll-Up captions. As you type the text, as soon as the text wraps around to 
the next row, the text is automatically sent out for captions. You may also press the  [+] key any time to 
send the text in the current row. 
 
For a details on how Speech Recognition software can be used for live captioning, check the document: 
www.cpcweb.com/TechSupport/CapMaker/SpeechRecognitionSoftware.pdf  
Captioning Video from Remote Location 
If you are captioning a video generated at a remote location, you need to connect your computer to the 
encoder located at the remote location via a telephone line using a modem attached to your computer. The 
encoder must have a built-in modem or a modem attached to it. If you have a Norpak enoder, you may 
also connect the encoder via a LAN or via internet. See Hardware Installation chapter for the details. 
 
Modem 
If you are using an external modem, you should see the name of the external modem appearing in the 
Modem Settings windows. You must have the external modem 
 
 

♦ Powered on. 
♦ Connected to the computer via a serial cable.  
♦ Must have been recognized by Windows when you power the computer on. 

 
Whether you have an internal modem built into your computer or an external modem attached to the 
computer, the process of choosing the modem is the same. You need to select both the caption device 
(encoder) and the modem. 
 

♦ First choose the caption device (encoder)  
♦ Then click on the Configure button inside the Caption Device dialog box. Check the 

box Connect via modem using inside the Caption Device Settings dialog box below 
and select your modem.  
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LAN and Internet 
If you are using a Norpak encoder, you can connect the encoder via a LAN connection or via an internet 
connection as long as the encoder is associated to an IP address. 
 
Click on Connect via Local Area Network (LAN) radio button. Type the IP address and Connection IP 
Port. 
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